安裝

系統需求
WordPress 香港中文版 4.6 及後續版本

  • PHP 5.2.4 或更高版本
  • MySQL 5.0 或更高版本

欲執行 WordPress 我們建議你的主機支援:

  • PHP 5.6 或更高版本
  • MySQL 5.6 或更高版本(或 MariaDB 10.0 或更高版本)
  • Apache mod_rewrite 模組 (多站台必備)(為使用「固定網址」等簡潔網址功能)
  • HTTPS

這是真的。我們推薦使用最強大且最具特色的 ApacheNginx 做為 WordPress 伺服器,但任何支援 PHP 和 MySQL 的伺服器亦可。也就是說,我們無法測試每一種可能的環境,但在網站空間頁面裡所列出的服務提供商都可以滿足上述需求。

注意:如果你在較為古老的環境下,只有舊版 PHP 或 MySQL 可用,WordPress 依然可以在 PHP 5.2.4+ 和 MySQL 5.0+ 運作,但這些版本已達產品壽命結束期(End-of-Life,EOL),可能會使你的網站有安全問題。
某些外掛或佈景主題無法在舊版本正常運作。請檢查外掛或佈景主題的兼容性、伺服器環境是否符合 WordPress 安裝需求。

直接詢問主機商

這裡是一封制式郵件,你可以直接寄給主機商;複製然後貼上!

I’m interested in running the open-source WordPress <https://wordpress.org/> web software and I was wondering if my account supported the following:

  • PHP 5.6 or greater
  • MySQL 5.6 or greater
  • The mod_rewrite Apache module

Thanks!

通常主機服務商的網站都會有顯示相關虛擬主機的規格,而且市面上許多虛擬主機都擁有執行WordPress必要的規格。如對該等主機對WordPress支援方面有任何疑問,請直接聯絡有關主機服務商。

雖不是必須,但為了最佳安全性仍建議這麼做

若要在空間上獲得更好的安全性,使用你的帳戶來執行 PHP 應用程式(像是 WordPress),而不是伺服器共用的預設帳戶。詢問你的主機商,他們使用的是哪一種方式,藉此提高你的網站安全。