WPSustainable

描述

Check the sustainability from your hosting company and the CO2 generated by your IP address.

Security

Found a security vulnerability? Please report it to us privately at the WPsustainable GitHub repository.

This plugin adheres to the following security measures and review protocols for each version:

Privacy

  • This plugin does not collect any information about your site, your identity, the plugins, themes or content the site has.

Vulnerabilities

  • No vulnerabilities have been published up to version 1.1.0.

Compatibility

1.1.0

  • WordPress: 5.2 – 6.4
  • PHP: 5.6 – 8.3
  • WPCS: 3.0.1

Contributors

You can contribute to this plugin at the WPsustainable GitHub repository.

Links

螢幕截圖

Blocks

This plugin provides 1 block.

  • Green Web Foundation Badge Shows a badge with the current color status from The Green Web Foundation.

安裝

Automatic download

Visit the plugin section in your WordPress, search for [wpsustainable]; download and install the plugin.

Manual download

Extract the contents of the ZIP and upload the contents to the /wp-content/plugins/wpsustainable/ directory. Once uploaded, it will appear in your plugin list.

常見問題

Where does the sustainability information come from?

Data is coming from The Green Web Foundation API.

評價

2022年11月18日
Suggestion: roll this into the Performance Lab plugin. It would also be cool, when and if the API starts offering more dynamic data, to offer a dashboard widget or some other way to present the information more prominently. Still, excellent.
閱讀全部1個評價

貢獻者及開發者

“WPSustainable” 是一個開源的軟體。以下的人對這個外掛作出了貢獻。

貢獻者

WPSustainable 外掛目前已有 3 個本地化語言版本。 感謝所有譯者為這個外掛做出的貢獻。

將 WPSustainable 外掛本地化為台灣繁體中文版。

對開發相關資訊感興趣?

任何人均可瀏覽程式碼、查看 SVN 存放庫,或透過 RSS 訂閱開發記錄

修改日誌

1.1.0

  • New security information (at WordPress.org plugin page).
  • New privacy information (at WordPress.org plugin page).
  • New compatibility information (at WordPress.org plugin page).
  • New vulnerabilities information (at WordPress.org plugin page).

  • New block: Badge

  • Compatibility checked with WPCS 3.0.1.

  • Compatibility: WordPress 5.2 – WordPress 6.4.

  • Compatibility: PHP 5.6 – PHP 8.3.
  • Compatibility: WordPress Coding Standards 3.0.1.

1.0.2

  • Minor updates
  • Check compatibility.

1.0.1

  • Check the texts and other files and things, not relevant at all.

1.0.0

  • First release.